KiCad Step by Step Tutorial JA

提供:KiCad.jp Wiki
移動: 案内, 検索
KiCad Step by Step Tutorial
Copyright c 2006 David Jahshan: kicad at iridec.com.au
2011 Update Copyright c 2011 Phil Hutchinson
(2012 仮翻訳版) c millo (Kicad.jp)


著作権: このドキュメントはどのようなフォーマットでも自由に複写、配布(販売あるいは無料配布) できます。 ドキュメントのメンテナに訂正やコメントを送ってください。 あなたは次のような派生品を作成し配布することができます。:

1. それが翻訳でない場合:著者へ派生品のコピーをメールしてください。

2. GPLの精神で派生品をライセンスします。著作権表示と、少なくとも使われているライセンスの指示を含んでください。

3. 前の著者と主要な貢献者に正当なクレジットを与えてください。

あなたが翻訳以外の派生品の作成を考えているなら、現在のメンテナと計画を議論する必要があります。


免責条項: このドキュメントの準備には注意を払いましたが、おそらく沢山の誤りがあります。 著者にそれをお知らせください。 これはフリードキュメントですので、著者はどの誤りについても法的責任を負いません。

トレードマーク: どのブランド名も商標であると仮定すべきです。そういった商標はそれぞれの所有者に帰属します。


KiCad は、回路図エディタとPCBレイアウトに対応した、オープンソース(GPL)な統合パッケージです。

KiCadは使用する前に、コンピュータへインストールする必要があります。このチュートリアルでは、KiCad が、[file:///C:/Kicad C:\Kicad]にインストールされていると仮定します。 あなたは、http://iut-tice.ujf-grenoble.fr/cao/ からKiCadのインストーラもしくは、コピーをダウンロードできます。

インストール手順はウェブサイト Infos:Install で参照できます。


  1. “KiCad.exe”を起動します。 
  2. メインウインドウが立ち上がります。[[Image:]]
  3. 新規プロジェクト作成: “ファイル” -> “新規”[[Image:]]
  4. メニュバー上の“新しいフォルダー”ボタンをクリックし、できた新しいフォルダーに“tute1”と名前をつけます。[[Image:]]
  5. 新しいフォルダー”上でダブルクリックしてフォルダーを開きます。
  6. ”ファイル名”にプロジェクト名を入れます。このチュートリアルの中では“tute1”とします。[[Image:]]
  7. 開く”をクリックします。プロジェクト名が、”tute1”に変わることに気がつきます。       [[Image:]]
  8. 回路図エディター”のアイコンをクリックする。[[Image:]]
  9. 「ファイルが見つかりません」というエラーダイアログが表示されるので、”OK”をクリックする。
  10. EESchema”のウインドウが表示されます。このウインドウは回路図の入力に使われます。
  11. 最初に回路図プロジェクトを保存します。“ファイル”->”全ての回路図プロジェクトを保存する”  [[Image:]]
  12. トップツールバーの”ページの設定”アイコンをクリックします。   [[Image:]]
  13. ページサイズを”A4”に選択し、”タイトル”を “Tute 1”と入力します。”OK”をクリックします。
  14. EESchemaのウインドウで、右側ツールバーにある“コンポーネントの配置” ボタンをクリックします。[[Image:]]
  15. 最初にコンポーネントを配置するために、編集ウインドウの赤い図枠の中央で、左クリックします。
  16. “コンポーネント選択”ダイアログが表示されます。
    [[Image:]]
  17. 全てのリスト”をクリックします。“ライブラリの選択”ダイアログが表示されます。
    [[Image:]]
  18. device” ライブラリ上でダブルクリックします。
  19. “コンポーネントの選択”ダイアログが表示されます。
  20. [[Image:]]下にスクロールして、””の上でダブルクリックします。 “コンポーネントの選択”ダイアログが閉じ 、回路図上に”R”コンポーネントが配置されます。
  21. シート中央の望む場所で左クリックすることにより、コンポーネントを配置します。
  22. ズームインするためにコンポーネント上で何度か拡大鏡のアイコンをクリックします。 [[Image:]]
  23. コンポーネントの上にマウスカーソルを合わせて、キーボードの'r' を入力します。 コンポーネントが、どのように回転するかに注目します。
  24. コンポーネントの中央で右クリックし、“コンポーネントの編集” -> “定数”を選択します。[[Image:]]
  25. “フィールド定数の編集” ダイアログが表示されます。
    [[Image:]]
  26. 現在の定数の”R”を”1k”に置き換えます。
  27. OK”をクリックします。
  28. 抵抗の中に定数が”1k”となります。.[[Image:]]
  29. 別の抵抗を配置するには、表示される抵抗を望む場所で左クリックします。
  30. “コンポーネントの選択:”ダイアログが表示されます。
  31. 前に選んだ抵抗が、履歴リスト上に”R”として表示されています。 [[Image:]]
  32. R”をクリックします。
  33. ページ上に抵抗を配置します。
  34. 繰り返し、ページ上に3番目の抵抗を配置します。
  35. 2番目の抵抗の上で右クリックして、”コンポーネント削除”をクリックします。これで回路図上からコンポーネントが取り除かれます。 [[Image:]]
  36. 3番目の抵抗上で右クリックし、 “コンポーネントの移動”を選択します。
  37. コンポーネントの位置変更で、位置を決めるため左クリックします。
  38. 3番目の抵抗において24から27のステップを繰り返し、“R”の値を“100”に置き換えます。
  39. 14から20のステップを繰り返します。 この際、“device”ライブラリの代わりに“microcontrollers” ライブラリを選び、“R” コンポーネントの代わりに、“PIC12C508A”コンポーネントを選びます。 [[Image:]]
  40. “microcontroller”コンポーネント上にマウスカーソルを合わせます。キーボードで'y' と 'x' を押します。 コンポーネントがx軸、Y軸でどう反転するかがわかります。 再度'y' と 'x'キーを押し、コンポーネントを元の方向に戻します。
  41. 14から20のステップを繰り返します。今度は、“device”ライブラリから“LED” コンポーネントを選びます。
  42. 次のようにページ上のコンポーネントを構成します:[[Image:]]
  43. ときとして、回路図に配置したいコンポーネントがコンポーネントライブラリにないことがあります。 そんなときはライブラリに新しいコンポーネントを追加しましょう。
  44. トップツールバーにある“ライブラリエディタ”の アイコンをクリックします。 [[Image:]]
  45. これによりコンポーネントライブラリエディタのウインドウが開きます。 [[Image:]]
  46. 作業ライブラリの選択” のボタンをクリックします。
    [[Image:]]
  47. “ライブラリの選択”のダイアログで、“conn”をクリックし 、“OK”をクリックします。
    [[Image:]]
  48. 新規コンポーネント”アイコンをクリックします。
    [[Image:]]
  49. コンポーネントプロパティダイアログが表示されます。 [[Image:]]
  50. 新しいコンポーネントを“MYCONN3”と名前を付けます。“標準のリファレンスのデジグネータ”として”J”を、”パッケージごとのパーツ数”に1を入力します。
  51. OK”をクリックします。
  52. もし「has a convert drawing」警告が 表示された場合には、“yes”をクリックします。.
  53. 画面中央にコンポーネントの名前が表示されます。それをズームインするため拡大鏡アイコンを2,3度クリックします。
  54. 右ツールバーにある“ピン追加”アイコンをクリックします [[Image:]]
  55. エディタ画面上の “MYCONN3”ラベルの下の部分をマウス左クリックします。
  56. “ピンプロパティ”ダイアログが表示され, ピン名には“VCC”を入力、ピン番号には“1”を入力、 “エレクトリック・タイプ” には“電源出力”を選択し、その後、“OK”をクリックします。
    [[Image:]]
  57. “MYCONN3”ラベルのちょうど下、好きな場所をクリックしてピンを配置します。
  58. 55から57までのステップを繰り返します。この時、“ピン名”は“INPUT”に、 'ピン番号”は “2”に、 “エレクトリックタイプ”は“電源入力”とします。
  59. 55から57までのステップを繰り返します。この時、“ピン名”は“GND”に、“ピン番号” は “3”に、“エレクトリックタイプ”は“電源出力”とします。
  60. このようにピンを配列します。:[[Image:]]
  61. 矩形入力”アイコンをクリックします。 [[Image:]]
  62. 下図のようにピンの周囲に長方形を描きたい場合は、長方形の左上コーナーとしたい所で左のマウスボタンをクリック&リリースし、そのまま長方形の右下としたい場所までマウスを動かし、再び左ボタンをクリックします。 [[Image:]]
  63. トップツールバー上で“現在のライブラリ内の現在のコンポーネントを更新”のアイコンをクリックします。 [[Image:]]
  64. トップツールバーにある”ディスクに現在のライブラリを保存(ファイル更新)”アイコンをクリックする。 [[Image:]]
  65. 表示される確認メッセージには”はい”をクリックします。
  66. “コンポーネントライブラリエディタ”のウインドウを閉じることができます。EESchemaウインドウに戻ります。
  67. 14から20までのステップを繰り返します。しかし今回は、ライブラリ“conn”から“MYCONN3”コンポーネントを使用しましょう。
  68. こうして、あなたが新しく作成した部品が表示されます。このコンポーネントを配置する場所を2番目の抵抗の近くに選びます。Y軸上で反転するために 'y' キーを押します。 [[Image:]]
  69. コンポーネント識別子"J?"が "MYCONN3"ラベルの下に表示されます。“J?”上で右クリックし 、“フィールドの移動”上をクリックします。この作業を行う前に、少し拡大すると便利かもしれません。 ピンの下に"J?"を再配置します。 [[Image:]]
  70. 右ツールバーにある“電源ポートの配置” アイコンをクリックします。 [[Image:]]
  71. 1kの抵抗のピンの上方をクリックします。
  72. “コンポーネント選択”ダイアログの中で、「全てのリスト」ボタンをクリックします。 [[Image:]]
  73. 下方にスクロールし、 ”コンポーネントの選択”ダイアログで、“VCC”を選択します。”OK”をクリックします。 [[Image:]]
  74. その部品を配置するため、1kの抵抗のピンの上方をクリックします。[[Image:]]
  75. マイクロコントローラの近くのVDDピンの上方をクリックします。
  76. “コンポーネントの選択の履歴”の中で“VCC”を選択し、VDD端子の隣に再度クリックします。
  77. もう一度繰り返し、"MYCONN3"のVCCピン上にVCCピンに配置します。
  78. 70から72までのステップを繰り返します。 この時はGNDを選択します。
  79. “MYCONN3”のGNDピンの下にGNDピンを配置します。
  80. マイクロコントローラのVSSピンの少し右下にもう1つのGNDシンボルを配置します。回路図はこのようになります。:[[Image:]]
  81. 右ツールバーにある“ワイヤの配置”アイコンをクリックします。 **このボタンのすぐ下にあり、線が太い“バスの配置”をピックしないよう注意しましょう。** [[Image:]]
  82. マイクロコントローラのピン7の端の小丸を左クリックし、それからLEDのピン2の小丸をクリックします。 [[Image:]]
  83. 下のようにコンポーネントをつなぐために、このプロセスを繰り返します。一方が接続されていない線を終了するためには、左マウスボタンをダブルクリックします。 VCCと GNDシンボルを配線する場合、VCCシンボルは下部を、GNDシンボルは上部中央をタッチすべきです。[[Image:]]
  84. 右ツールバーにある “ネット名の配置”のアイコン上でクリックしてネット名をつけます。 [[Image:]]
  85. マイクロコントローラとLEDの間の配線の中央をクリックします。
  86. “uCtoLED”という名前を入力します。
  87. ピン7の小丸の近く(少し右)をクリックし、ネット名を配置します。
  88. 抵抗とLED間の配線を“LEDtoR”と名付けます。
  89. “MYCONN3”から抵抗までの間の配線を“INPUTtoR”と名付けます。
  90. 100Ωの抵抗の右にある配線を“INPUT”と名付けます。
  91. ピン6からの線を“INPUT”と名付けると、 これにより“INPUT”とラベルされた2つのピンの間に見えない接続が設定されます。これは線が混雑した複雑なデザインの場合に便利な配線テクニックです。
  92. VCCとGNDの線にラベルをつける必要はありません。 そのラベルは、接続されている電源オブジェクトから暗黙的に定義されています。[[Image:]]
  93. プログラムは、配線ミスをチェックします。接続されていない電線は、警告を生成することがあります。これらの警告を避けるため、ワイヤが接続されていないのが意図的であることをプログラムに指示することができます。
  94. 右ツールバーにある“空き端子フラグを配置”というアイコンをクリックします。 [[Image:]]
  95. 2, 3, 4と 5の線の端にある小丸の上でクリックします。 Xは接続の欠落が意図的であることを表明し表示するものです。[[Image:]]
  96. 回路上にコメントを追加するには、右ツールバーにある”グラフィックテキスト(コメント)配置”を使います。 [[Image:]]
  97. コンポーネントは、ユニーク(一意)な識別子とする必要があります。このため、“回路図のアノテート”アイコンをクリックします。
    [[Image:]]
  98. “回路図のアノテーション”ウインドウでは、 “現在のページでのみ使用”を選択し、“アノテーション”ボタンをクリックします。
    [[Image:]]
  99. 確認ダイアログで“OK”をクリックします。“回路図のアノテーション”ウインドウの“閉じる” をクリックします。
  100. コンポーネントのすべての"?"が数字に置き換えられたことがわかります。各識別子は一意(重複なし)です。例えば、"R1"、"R2"、"U1"、 "D1"と "J1"。
  101. ERCの実行”アイコンをクリックします。表示されたウインドウにある“ERCのテスト”ボタンをクリックします。
    [[Image:]]
  102. これは、配線が切れているなどのエラーや警告を通知するレポートが生成されます。エラー0、警告0にすべきです。 ミスをした場合には、小さな緑色の矢印がエラーの場所に表示されます 。エラーの詳細情報を得るため“ERCレポートの作成”をクリックし、“ERCのテスト”ボタンを再度押します。
  103. トップツールバーにある“ネットリストの生成”アイコン上をクリックします。 [[Image:]]
  104. ネットリスト”をクリックし、デフォルトのファイル名で“保存”をクリックします。
  105. [[Image:]]トップツールバーにある“Cvpcbを実行” アイコンをクリックします。
    [[Image:]]
  106. コンポーネントライブラリを開くことができないというエラーがある場合は、OKをクリックします。
  107. Cvpcbにより、コンポーネントにフットプリントをリンクすることができます。左側のペインで“D1”を選択します。右側のペインで“LEDV”までスクロールダウンして、それをダブルクリックします。[[Image:]]
  108. “J1”に対して、“3PIN_6mm”というフットプリントを選択します。
  109. “R1”と“R2”に対して、薄緑画面から“R1”というフットプリントを選択します。
  110. “U1”には“DIP-8__300”を選択します
  111. “ファイル”->”名前をつけて保存”をクリックします。デフォルト名“tute1.net”は大丈夫なので保存をクリックします。
  112. Eeschemaエディタに戻り、“ファイル” -> “全ての回路図プロジェクトを保存”をクリックしてプロジェクトを保存します。
  113. KiCadのメインウインドウに切り替えます。
  114. “ブラウズ” -> “ファイル表示”を選択します。[[Image:]]
  115. エラーメッセージが表示される場合、テキストブラウザを選択します。大部分のWindowsのコンピュータには“c:\windows\system32\notepad.exe”にテキストブラウザがあります。
  116. “tute1.net”というファイルを選択します。これでネットリストファイルが開きます。それは、どのコンポーネントと、どのピンがどのピンに接続されているかを記述しています。
  117. テキストエディタを閉じ、“EESchema” ウインドウに戻ります。
  118. 部品表を作成するには、トップツールバーにある“部品表”アイコンをクリックします。 [[Image:]]
  119. 設定ダイアログ上で“OK”をクリックし、それから“保存”ボタンをクリックします。
  120. そのファイルを見るため113-115 のステップを繰り返し、“tute1.lst”を選択します。
  121. テキストエディタを閉じます。.
  122. トップツールバーにある“Pcbnewの実行”アイコンをクリックします。[[Image:]]
  123. Pcbnew”ウインドウが開かれます。
  124. ファイルが存在しないというエラーメッセージには“OK”をクリックします。
  125. “ファイル” -> “保存”をクリックします。
  126. トップツールバー上にある“ページ設定”アイコンをクリックします。
    [[Image:]]
  127. “ページサイズ”を“A4”に選び、タイトルを “Tute 1”と入力します。
  128. PCBメーカーが要求するクリアランスと最小配線幅を設定することは、よい考えです。この一例としてクリアランスを0.015に、最小配線幅を0.01に設定してみます。
  129. メニュの“デザインルール” -> “デザインルール”をクリックします。 [[Image:]]
  130. "ネットクラス・エディタ"が表示されていなければ、"ネットクラス・エディタ"のタブをクリックします。
  131. ウインドウの上部にある“クリアランス”のフィールドを“0.015”に、“配線幅”のフィールドを“0.01”に変更します。[[Image:]]
  132. グローバルデザインルール”タブ上でクリックし、“最小の配線幅”を0.01”にフットします。[[Image:]]
  133. 変更をコミットするためOKボタンをクリックし、デザインルールエディタのウインドウを閉じます。
  134. トップツールバーにある“ネットリストの読み込み”アイコンをクリックします。 [[Image:]]
  135. ネットリストファイルを参照する”ボタンをクリックし、選択ダイアログの中で“tute1.net”を選択し、 “現在のネットリストを読み込む”上をクリックします。その後、“閉じる”ボタンをクリックします。 [[Image:]]
  136. コンポーネントは、ちょうどページ上、左上隅に配置されます。見えない場合にはスクロールアップします。
  137. コンポーネント上で右クリックして、メニュの上部にあるコンポーネントの名前をクリック後、“移動”をクリックします。基板の中央にコンポーネントを移動します。
    [[Image:]]
  138. 全てのコンポーネントがページの中央にくるまで前のステップを繰り返します。
  139. ボードのラッツネストを非表示”のアイコンが選択されていることを確認します。 そうするとコンポーネントをつなぐ配線のラッツネストが見えます。 (注: ツールチップは後方; ラッツネストを表示するこのボタンを押す) [[Image:]]
  140. 配線の交差数が最小となるまでコンポーネントを移動します。[[Image:]]
  141. ラッツネストが消えたり、画面が乱れてきた場合には、右クリックして"ビューの再描画"をクリックします。
  142. "表面"レイヤ上のグランド配線を除き、全ての配線を接続します。
  143. トップツールバーにあるプルダウンメニュで“表面”を選択します。 [[Image:]]
  144. 右ツールバーにある“配線とビアの追加”アイコンをクリックします。
    [[Image:]]
  145. “J1”のピン1の中央をクリックし、“R2”パッドへの配線を引きます。配線の終点を設定するため、ダブルクリックします。
  146. J1のピン3を除く全ての配線が接続されるまで、このプロセスを繰り返します。[[Image:]]
  147. トップツールバーにあるプルダウンメニュで、“裏面” を選択します。
  148. “配線とビアの追加”アイコンをクリックします。
  149. J1のピン3 とU1のピン8間の配線を引きます。
  150. 右ツールバーにある“ネットをハイライト”アイコン上をクリックします。 [[Image:]]
  151. J1のピン3上をクリックします。 黄色に変わります。
  152. 右ツールバーにある“塗りつぶしゾーンの追加”アイコンをクリックします。
    [[Image:]]
  153. 基板の周囲に長方形を描く予定で、望むコーナーの1つをクリックします。 表示されたダイアログの中で、“Pad in Zone:”を“Thermal relief”に、“Zone edges orient:”を“H,V”に設定、”OK”をクリックします。
  154. 順番にそれぞれのコーナーでクリックして基板の外形を描きます。長方形の終端でダブルクリックします。
  155. 描いた領域の内側で右クリックします。
  156. “Fill or Refill All Zones”をクリックすると、基板は緑色に塗りつぶされます。
  157. 基板はこのように見えるはずです:[[Image:]]
  158. トップツールバーのプルダウンメニュから“基板外形”を選択します。
  159. 右ツールバーにある“図形ライン(またはポリゴン)を入力”のアイコンを選択します。[[Image:]]
  160. 基板の各コーナーをクリックして基板外形をトレースします。PCBの端部と緑色端部の間には小さなギャップが残ることを覚えておいてください。
  161. デザインルールチェックの実行”をクリックして、デザインルールチェックを実行します。
    [[Image:]]
  162. DRCの起動”をクリックします。 エラーは存在しないはずです。
  163. 未結線情報のリスト”をクリックします。未結線はあってはいけません。
  164. OK”をクリックして DRCコントロールダイアログを閉じます。
  165. “ファイル” -> “Save”をクリックしてファイルを保存します。
  166. 3Dでボードを閲覧するために、“3D Display” -> “3D Display”上でクリックします。
  167. PCBの周囲でマウスをドラッグしてPCBを回転させることができます。[[Image:]][[Image:]]
  168. これでボードは完成です。メーカーに送るためのガーバーファイルを生成する必要があります。
  169. “ファイル” -> “出図”をクリックします。
  170. ”作図フォーマット”として“ガーバー”を選択し、”プロット”ボタンをクリックします。 ”閉じる”をクリックしてプロットダイアログを閉じます。
  171. ガーバーファイルを見るため、メインのKiCad ウインドウへ移動します。
  172. GerbView”アイコンをクリックします。
    [[Image:]]
  173. プルダウンメニュで“Layer 1”を選択します。
  174. “ファイル” -> “ガーバーファイルを読み込む”をクリックします。 [[Image:]]
  175. “tute1-Front.gtl”という名称のファイルを選択し、”開く”をクリックします。[[Image:]]
  176. 173から175のステップを繰り返します。この時、“Layer 2”を選択し、“tute1-Back.gbl”を読み込みます。
  177. 173から175までのステップを繰り返します。この際、“Layer 3”を選択し、“tute1-SilkS_Front.gbo”を読み込みます。
  178. 173から175までのステップを繰り返します。この際、“Layer 4”を選択し、“tute1-SilkS_Back.gbo”を読み込みます。こうして、製造メーカーへ送るレイヤを試験できます。Kicadには広範囲にわたるフットプリントライブラリがあります。しかしながら場合によってはKicadライブラリの中にあなたが必要とするフットプリントがないこともあるかもしれません。 そこで、ここではKiCadにおける新規のPCBフットプリント作成ステップを紹介します。:
  179. PCBnewウインドウに戻ります。
  180. トップツールバーにある“モジュールエディタを開く” アイコンをクリックします。 [[Image:]]
  181. これにより“Module Editor”が開きます。
  182. トップツールバーにある“アクティブなライブラリを選択してください”をクリックします。 [[Image:]]
  183. この演習では、“connect” ライブラリを選択します。
  184. トップツールバーにある“新規モジュール”アイコンをクリックします。 [[Image:]]
  185. モジュール設定”に“MYCONN3”を入力します。
  186. 画面中央に“MYCONN3”ラベルが表示されます。
  187. そのラベルの下に“VAL**”があります。
  188. “MYCONN3”の上で右クリックし、“VAL**”の上方に移動します。
  189. “VAL**”上で右クリックして、“モジュールテキストの編集” を選び、“SMD”にリネームします。
  190. テキストプロパティの“表示”の項目に“非表示”を選択します。.
  191. 右ツールバーにある “パッド入力”を選択します。
  192. [[Image:]]パッドを配置するため画面をクリックします。
  193. 新しいパッド上で右クリックし、“Edit Pad”をクリックします。 [[Image:]]
  194. Set the “パッド番号”を “1”に、“パッドの形”を“矩形”に、“パッドのタイプ”を“SMD”に、 “パッド幅X”を“0.4”に、“パッド幅Y”を“0.8”に設定し、“OK”をクリックします。
  195. 再度“パッド入力”をクリックし、 もう2つパッドを配置します。
  196. 上の図のように外に“MYCONN3”と“SMD”のラベルを移動します。[[Image:]]
  197. 右ツールバーにある“図形ライン(またはポリゴン)を入力”のアイコンをクリックします。
    [[Image:]]
  198. コンポーネントの周囲にコネクタの外形を描きます。 [[Image:]]
  199. トップツールバーにある “アクティブなライブラリにモジュールを保存”をクリックし、デフォルト名のMYCONN3で保存します。[[Image:]]
  200. PCBnewに戻り 、右ツールバーにある“モジュールの追加” アイコンをクリックします。
  201. [[Image:]]画面をクリック、するとモジュール名がポップアップします。
  202. モジュール“MYCONN3”を選択し、 それをPCBデザインに配置します。

これで、KiCadの大部分の機能についての簡単なチュートリアルが終わりました。 さらに詳細なインストラクションについては、すべてのKiCadモジュールからアクセスすることができる、詳細なヘルプファイルがあります(訳者注:日本語版は翻訳中です)。 そのためには,ヘルプ -> 内容をクリックしてください。

個人用ツール
名前空間

変種
操作
案内
ツールボックス