過去に出た質問

提供:KiCad.jp Wiki
(版間での差分)
移動: 案内, 検索
(GNDビアは作れますか?)
(Pcbnew関連: 等長配線の方法について追記.)
54行: 54行:
 
===GNDビアは作れますか?===
 
===GNDビアは作れますか?===
 
[[ファイル:GndVia.png|right|300px]]
 
[[ファイル:GndVia.png|right|300px]]
多層基板において,GNDへの電流リターン経路を確保するためといった理由であける,層間のGNDを接続するビアですが,右図のようにGND端子から配線を伸ばし,「V」でビアを好きなだけ打った後,ダブルクリックで配線を終了します.<br clear="all">
+
多層基板において,GNDへの電流リターン経路を確保するためといった理由であける,層間のGNDを接続するビアですが,右図のようにGND端子から配線を伸ばし,「V」でビアを好きなだけ打った後,ダブルクリックで配線を終了します.<br clear="all" />
  
 
===複数枚をレイアウト出力(面付け)するためには,どうすれば良いですか?===
 
===複数枚をレイアウト出力(面付け)するためには,どうすれば良いですか?===
85行: 85行:
 
#オートルータ or 全てのゾーンを削除⇒再度塗りつぶし
 
#オートルータ or 全てのゾーンを削除⇒再度塗りつぶし
  
ヘルプの「Adding a cutout area inside a zone」や,[http://www.youtube.com/watch?v=1gCLCpsalZU 動画によるチュートリアル(英語)]も合わせて参照のこと.<br>
+
ヘルプの「Adding a cutout area inside a zone」や,[http://www.youtube.com/watch?v=1gCLCpsalZU 動画によるチュートリアル(英語)]も合わせて参照のこと.<br />
<br>
+
<br />
 
また,円形状のゾーンの切り抜きはデフォルトではできないため,基板外形などDRCのかかるレイヤで円を描き,その後ゾーンを塗りつぶす事で円形の抜きが作成可能.
 
また,円形状のゾーンの切り抜きはデフォルトではできないため,基板外形などDRCのかかるレイヤで円を描き,その後ゾーンを塗りつぶす事で円形の抜きが作成可能.
 
*ただし,抜き作成後に基板外形を削除し,再度ゾーンの塗りつぶしを行うと抜きが消えてしまうので扱いに注意が必要.DRCエラーの修正後,ガーバー作成直前の削除がお勧め.
 
*ただし,抜き作成後に基板外形を削除し,再度ゾーンの塗りつぶしを行うと抜きが消えてしまうので扱いに注意が必要.DRCエラーの修正後,ガーバー作成直前の削除がお勧め.
  
 
===文字の大きさや図形線の太さのデフォルト値を変更する方法===
 
===文字の大きさや図形線の太さのデフォルト値を変更する方法===
メニューから, 「Preferences → 寸法 → Texts and Drawings」.<br>
+
メニューから, 「Preferences → 寸法 → Texts and Drawings」.<br />
 
リファレンス、定数のサイズを一括変更したい場合には,「編集 → モジュールの~~サイズをリセット」にて,上記で設定したデフォルト値へ一括変更が可能.
 
リファレンス、定数のサイズを一括変更したい場合には,「編集 → モジュールの~~サイズをリセット」にて,上記で設定したデフォルト値へ一括変更が可能.
  
 
===コンポーネントライブラリエディタで2コイチの部品を作る方法===
 
===コンポーネントライブラリエディタで2コイチの部品を作る方法===
GUI上ではできない.<br>
+
GUI上ではできない.<br />
 
KiCadのコンポーネントファイルはテキストで構成されているので,ファイルをテキストエディタで直接編集することで可能.[http://tech.groups.yahoo.com/group/kicad-users/message/11598 参考]
 
KiCadのコンポーネントファイルはテキストで構成されているので,ファイルをテキストエディタで直接編集することで可能.[http://tech.groups.yahoo.com/group/kicad-users/message/11598 参考]
  
 
===FreeRoute用にエクスポートしたdsnファイルが読込めない===
 
===FreeRoute用にエクスポートしたdsnファイルが読込めない===
使用しているレイヤー名,部品名,<u>プロジェクトが配置されているフォルダ名</u>などに日本語などの全角文字が入っていると,「loading design ***.dsn」 (***はファイル名)」から進まないようです.これらを全て半角アルファベットのみに変更してください.<br>
+
使用しているレイヤー名,部品名,<u>プロジェクトが配置されているフォルダ名</u>などに日本語などの全角文字が入っていると,「loading design ***.dsn」 (***はファイル名)」から進まないようです.これらを全て半角アルファベットのみに変更してください.<br />
 
PcbNewから出力したdsnファイルはテキストエディタで開けるので,それを見ると,どこに全角文字が残っているか確認できます.
 
PcbNewから出力したdsnファイルはテキストエディタで開けるので,それを見ると,どこに全角文字が残っているか確認できます.
  
106行: 106行:
 
KiCadはコンポーネントとモジュールの間でピン一本一本への関連付けが存在しないため,どちらも1から始まる連番であることが暗黙の了解となっています.<br>
 
KiCadはコンポーネントとモジュールの間でピン一本一本への関連付けが存在しないため,どちらも1から始まる連番であることが暗黙の了解となっています.<br>
 
そのため,自作のモジュールを使ったネットリストの読込み時に,右図のようなエラーが出る場合は,ピンの番号がずれていないか確認してください.<br/>
 
そのため,自作のモジュールを使ったネットリストの読込み時に,右図のようなエラーが出る場合は,ピンの番号がずれていないか確認してください.<br/>
この図の場合は,P11のモジュールに"1", "2", "3"といった名前のパッドが見つからないというエラーがメッセージ欄に出力されています.<br clear="all">
+
この図の場合は,P11のモジュールに"1", "2", "3"といった名前のパッドが見つからないというエラーがメッセージ欄に出力されています.<br clear="all" />
  
 
===リファレンスや定数のシルクの大きさを一括で変更するには?===
 
===リファレンスや定数のシルクの大きさを一括で変更するには?===
 
編集 > Reset Module Field Sizesで,出てきたダイアログでReferenceや定数をチェックして,文字のサイズを指定してリサイズ.
 
編集 > Reset Module Field Sizesで,出てきたダイアログでReferenceや定数をチェックして,文字のサイズを指定してリサイズ.
 +
 +
===等長配線はどうするのか?===
 +
配線を左クリックすると下図のように配線長が表示されるので,これを参考に手動で引き直してください.<br />
 +
[[ファイル:Wire_length.png|center|600px]]<br clear="all" />
  
 
==BItmap2Component関連==
 
==BItmap2Component関連==

2013年10月25日 (金) 11:36時点における版

  • このページでは,過去にメーリングリストやTwitter上で出たQ&Aをまとめています.誰でも良いので,どんどん書き加えていってください(切実)

目次

全般

KiCad日本語版が起動しない

アプリケーションを起動しようとすると,「MSVCP100.dllが見つからなかったためこのアプリケーションを開始できませんでした。」というエラーメッセージが出て起動しない場合,コンピュータにVisual C++2010のランタイムがインストールされていません.Microsoft公式から,ランタイムをインストールしてください.

KiCad日本語版をダウンロードすると,アンチウイルスソフトに削除される

当サイトからKiCad日本語版をダウンロードすると,ノートン インターネットセキュリティ/アンチウイルスにて「WS.Reputation.1」の脅威が検出され,ファイルが削除される場合があります.この脅威は,Web上で配布されているアプリケーションの中で,シマンテック社により「多くの人に使用されている実績がない」と評価されたアプリケーションに対して付加されてしまうもので,実際にコンピュータに危害を与える可能性があるかの評価ではありません.(参考:シマンテック社:WS.Reputation.1の検出について

このような場合,ノートンの製品画面のメイン画面内にある「検疫」タブから,誤検出で削除されたファイルを復元することができます.復元方法について,詳しくはノートン社のWebページをご覧ください.
シマンテック社:WS.Reputation.1の検出について

kicad.jpとしては,今後はこのようなことがないよう,KiCad日本語版をウイルスチェックのホワイトリストに加えるようシマンテック社に求めていく方針です.シマンテック社が応じるまで,ユーザーの皆さまにはお手数をおかけしますが,上記の復元を行ってKiCad日本語版を使用していただきますよう,ご協力をお願いいたします.

ライブラリ関連

デフォルトのライブラリ以外にKiCadの公開ライブラリはありますか?

主に http://www.kicadlib.org/ http://kicad.rohrbacher.net 辺りにたくさんあります.

スペイン語ですが, http://per.launay.free.fr/kicad/kicad_php/composant.php の下部にあるフォームに部品名を入力して、横の「validar」ボタンを押すと,上記のサイトから対応するコンポーネントの入ったライブラリを検索できるようです.

自作したGNDコンポーネントがGNDに接続されない

電源コンポーネントはKiCad内で特別扱いされているので,ヘルプの「11.8 - Create power port symbols」あたりを参照して, コンポーネントを作成するときに,リファレンスの頭に「#」をつける.
また,最新バージョンのライブラリエディタだと,上部ツールバーの「コンポーネント プロパティの編集」から,「電源シンボル」のプロパティを変更することができる.

ICのシンボルやフットプリントを自動生成する機能はありますか?

英語サイトですが, http://kicad.rohrbacher.net/quicklib.php http://kicad.rohrbacher.net/quickmod.php こちらのサイトで生成することができます.

EeSchema関連

Linux環境で印刷すると,カクカクしたフォントになってしまう

Cupsを経由するとフォントが低解像度のものになってしまうので, SVGでプロットしたものを,INKSCAPEというアプリで印刷したり,pdfに変換したりする.
参考: http://tech.groups.yahoo.com/group/kicad-users/message/10623

間違って登録したコンポーネントの削除

ツール→ライブラリエディタを開き,画面左上から2番目の本のアイコン「作業ライブラリの選択」で登録してしまったライブラリを選択する.その後,隣のゴミ箱アイコン「現在のライブラリのコンポーネントを削除」を押して,開いたダイアログから削除したいコンポーネントを選ぶ.

CvPcb関連

「cvpcb.exeは動作を停止しました」という警告が出て停止してしまう

ネットリストの端子名に()等の記号が入っていないかチェックし,入っていたら削除する.

Pcbnew関連

スルーホールはどうしたら作れますか?

配線中にキーボードの「V」キーを押してください.

GNDビアは作れますか?

GndVia.png

多層基板において,GNDへの電流リターン経路を確保するためといった理由であける,層間のGNDを接続するビアですが,右図のようにGND端子から配線を伸ばし,「V」でビアを好きなだけ打った後,ダブルクリックで配線を終了します.

複数枚をレイアウト出力(面付け)するためには,どうすれば良いですか?

面付けしたいPcbnewのデータ(元データ)はすでにあるものとします.

  1. 新規にPcbnewを立ち上げる.
  2. メニューから「ファイル」-「ボードを追加」.
  3. 面付けしたいボードの元データ(xxx.brd)を読み込む.
  4. 3を必要な分だけ繰り返す.
  5. 基板の配置を整える.

トラブル回避のための注意

  • 元データの「グリッドの原点」をいじらない.

 いじってしまうと正確な面付けが出来なくなる.

  • 元データと面付けデータのグリッドサイズを揃える.

 0.1mm単位に面付けしたければ,両方ともグリッドサイズを0.1mmにする.

  • 一つ目のデータを読み込むんだら,それをシート上の別の場所に移動する.

 移動しないと2つ目が同じ場所に表示されて重なってしまう.

  • ラッツネストが元データ間でつながってしまうが,問題はない.

 表示をオフにすれば見やすくなる.

配線の幅を指定するには,どうすれば良いですか?

基板作成時に,デザインルールエディタ>グローバルデザインルールで,カスタムビアサイズやカスタム配線パターン幅を登録する.
すると,配線時に右クリックメニューで登録したビアや配線幅が出てきて,選択できる.

塗りつぶしゾーンの内部に塗りつぶさない領域を指定する方法

  1. 「塗りつぶしゾーンの追加」ツールを選択
  2. 切り抜くゾーンの”外周部分を”クリック
  3. 「切り抜いたエリアの追加」を選択
  4. ポリゴンで切り抜きエリアを描く
  5. オートルータ or 全てのゾーンを削除⇒再度塗りつぶし

ヘルプの「Adding a cutout area inside a zone」や,動画によるチュートリアル(英語)も合わせて参照のこと.

また,円形状のゾーンの切り抜きはデフォルトではできないため,基板外形などDRCのかかるレイヤで円を描き,その後ゾーンを塗りつぶす事で円形の抜きが作成可能.

  • ただし,抜き作成後に基板外形を削除し,再度ゾーンの塗りつぶしを行うと抜きが消えてしまうので扱いに注意が必要.DRCエラーの修正後,ガーバー作成直前の削除がお勧め.

文字の大きさや図形線の太さのデフォルト値を変更する方法

メニューから, 「Preferences → 寸法 → Texts and Drawings」.
リファレンス、定数のサイズを一括変更したい場合には,「編集 → モジュールの~~サイズをリセット」にて,上記で設定したデフォルト値へ一括変更が可能.

コンポーネントライブラリエディタで2コイチの部品を作る方法

GUI上ではできない.
KiCadのコンポーネントファイルはテキストで構成されているので,ファイルをテキストエディタで直接編集することで可能.参考

FreeRoute用にエクスポートしたdsnファイルが読込めない

使用しているレイヤー名,部品名,プロジェクトが配置されているフォルダ名などに日本語などの全角文字が入っていると,「loading design ***.dsn」 (***はファイル名)」から進まないようです.これらを全て半角アルファベットのみに変更してください.
PcbNewから出力したdsnファイルはテキストエディタで開けるので,それを見ると,どこに全角文字が残っているか確認できます.

ネットリストの読込み時に,自作したモジュールだけ読込めない

NetListLoadError01.png

KiCadはコンポーネントとモジュールの間でピン一本一本への関連付けが存在しないため,どちらも1から始まる連番であることが暗黙の了解となっています.
そのため,自作のモジュールを使ったネットリストの読込み時に,右図のようなエラーが出る場合は,ピンの番号がずれていないか確認してください.
この図の場合は,P11のモジュールに"1", "2", "3"といった名前のパッドが見つからないというエラーがメッセージ欄に出力されています.

リファレンスや定数のシルクの大きさを一括で変更するには?

編集 > Reset Module Field Sizesで,出てきたダイアログでReferenceや定数をチェックして,文字のサイズを指定してリサイズ.

等長配線はどうするのか?

配線を左クリックすると下図のように配線長が表示されるので,これを参考に手動で引き直してください.

Wire length.png

BItmap2Component関連

作成したロゴをリサイズする方法

  1. Bitmap2Componentから.empで出力.
  2. http://escalalibre.com/edwt/kicad_sizeConverter.php でリサイズ.

発注

作成した基板データを海外の基板屋に発注するには,どうすれば良いですか?

RenameFileNameFromJapaneseToEnglish.png

各基板屋のデザインルールにそって,基板データを作成してください.
プロットした基板データは,ファイル名が日本語になっていると思うので,それを英語表記に変更してください.Seeed Studioに発注する場合の変更例を右図に示します.

基板外形のデータをシルク表面にコピーするためには,どうすれば良いですか?

Pcbnew DrawEdge.png

プロットする際に,「Exclude PCB edge layer from other layers」の項目のチェックを外すと,基板外形以外の全てのレイヤーにも外形の情報が書き込まれます.

個人用ツール
名前空間

変種
操作
案内
ツールボックス